headerphoto
My money monitor
mymoneymonitor
What are BrowserSeal system requirements?

BrowserSeal runs on of the following Windows versions - 2000, XP, Vista or 7 (32 or 64 bit). It requires 32 bit Java Runtime Environment (JRE) version 1.5 and above, which is most probably already installed on your PC.